Driver/MP3Comm.inf Driver File Contents (dmp100_win2k_driver_022001.exe)

Driver Package File Name: dmp100_win2k_driver_022001.exe
File Size: 1.2 MB

;/*++
;
;Copyright (c) K71. 2000 PINE Group.
;For MP3 Player on ECP PortIO
;
;--*/

[Version]
Signature="$WINDOWS NT$"
Class=MP3Player
ClassGuid={FED4B2B9-0515-40ba-833A-8C41895E81C9}
Provider=%PINE%
DriverVer=12/15/2000,2.00.7101

[DestinationDirs]
DefaultDestDir = 12

; ================= Class section =====================

[ClassInstall32]
Addreg=SampleClassReg     

[SampleClassReg]
HKR,,,0,%ClassName%
HKR,,Icon,,-5

; ================= Device Install section =====================

[Manufacturer]
%PINE%=MSFT

[SourceDiskFiles]
genport.sys=1

[SourceDiskNames]
1="Install disk",

[MSFT]
; DisplayName            Section           DeviceId
; -----------       	 -------           --------
%PortIO.DRVDESC%=PortIO_Inst,root\portio

[PortIO_Inst.NT]
CopyFiles=PortIO.CopyFiles
LogConfig=PortIO.LC0, PortIO.LC1

[PortIO.CopyFiles]
MP3Comm.sys

[PortIO_Inst.NT.Services]
AddService=portio,0x00000002,PortIO_Service 

;Uncomment following lines if your device can only work with factory default settings
;[PortIO.NT.FactDef]
;ConfigPriority=HARDRECONFIG
;IOConfig=300-303(3ff::)  ; 10 bit decode ranging from 300 - 303

[PortIO.LC0]
ConfigPriority=DESIRED 
IOConfig=300-303(3ff::)  ; 10 bit decode ranging from 300 - 303

[PortIO.LC1]
ConfigPriority=NORMAL
IOConfig=4@300-3ff(3ff::) ; 4 ports starting anywhere between 300 and 3fc

[PortIO_Service]
DisplayName    = %PortIO.SVCDESC%                            
ServiceType    = 1                  ; SERVICE_KERNEL_DRIVER
StartType      = 3                  ; SERVICE_DEMAND_START
ErrorControl   = 1                  ; SERVICE_ERROR_NORMAL
ServiceBinary  = %12%\Mp3Comm.sys                            

[Strings]
PINE = "PINE_Corp"
ClassName = "MP3Player Drivers"
PortIO.SVCDESC = "MP3 Player Service"
PortIO.DRVDESC = "MP3 Player Driver"
;DEFINE_GUID(MP3_Guid, 
;0xfed4b2b9, 0x515, 0x40ba, 0x83, 0x3a, 0x8c, 0x41, 0x89, 0x5e, 0x81, 0xc9)
server: web4, load: 0.75